Image Please bare with us while we are carrying out some much needed maintenance to the forum. New look coming soon!

Idling high 3SGE

Any problems with your Altezza, post questions here
Madazphotos
Noob!
Posts: 3
Joined: Sun Feb 04, 2018 8:42 pm
Location: New Zealand
Contact:

Idling high 3SGE

Postby Madazphotos » Sun Mar 25, 2018 7:29 am

Every time I disconnect the battery terminals my car does this.

So I had to disconnect my battery to remove the airbag and In doing so it now idles real high the last time it did this it took like 3 months to come right and when driving along and you put your foot on the clutch the idle starts bouncing up and down

felix0315
Noob!
Posts: 3
Joined: Fri Feb 19, 2016 7:09 am

Re: Idling high 3SGE

Postby felix0315 » Mon Mar 26, 2018 8:55 pm

Idling high after a battery disconnect is quite normal. You basically reset the ECU of its calibration memory. The car will run on 'default' until it re-learns the environment and dials itself in. This is usually a short process so just drive as you would normally.

If it is abnormal as you are observing, I would look into cleaning the MAF sensor to begin.

Madazphotos
Noob!
Posts: 3
Joined: Sun Feb 04, 2018 8:42 pm
Location: New Zealand
Contact:

Re: Idling high 3SGE

Postby Madazphotos » Mon Apr 02, 2018 7:47 am

felix0315 wrote:Idling high after a battery disconnect is quite normal. You basically reset the ECU of its calibration memory. The car will run on 'default' until it re-learns the environment and dials itself in. This is usually a short process so just drive as you would normally.

If it is abnormal as you are observing, I would look into cleaning the MAF sensor to begin.


I took it for an hour drive and still didn’t fix it and that was 1 hour there and 1 back


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 1 guest