ImageGreetings! Welcome to Tezzaworld website, unfortunately you are a few years late to the show as nearly everyone has been and gone, there is still lots of useful archived material to read through, not many active users unfortunately, but that’s the way it goes, hopefully you are not too disappointed...

No Power and limiting problem

Any problems with your Altezza, post questions here
Bref92-Tez
Noob!
Posts: 3
Joined: Thu May 31, 2018 11:42 am

No Power and limiting problem

Postby Bref92-Tez » Fri Jun 29, 2018 11:56 pm

Hey, any help much appreciated.... :roll:

Long story so sorry in advance.

Started when I was testing my 99 tezz, I had to change my straight through to put a cat in for test. The car started limiting out around 6/6.5 rpm but just assumed it was as a result of the cat, she was still hitting vvti though. She passed test and changed back to the straight through exhaust but was still limiting out early and started to get worse. She started to limit at 5.5rpm then dropped to 4.5rpm. At this stage she was down on power, not hitting vvti and limiting at different stages. I changed the crank shaft sensor (advised to do this) no difference. I then changed bank 1 vvti soliniod and she was going up in the revs but still not hitting vvti. Changed bank 2, no difference and now is limiting at 3rpm and popping like mad when hitting near there.

To date I have:
Cleaned out the MAF sensor and throttle body (as she was ideling funny)
Changed the crank shaft sensor (no difference)
Changed bank 1 and 2 vvti sensor (slight improvement but still not right and has since started to deteriorate)
No engine management light up (light comes on so it's working)
Ran a diagnostic and no related faults reading

Any idea what it could be?

I may have forgotten things so will update if anything comes to mind.

User avatar
RS Tom-Hundred
Tezza Fanatic!
Posts: 468
Joined: Fri Nov 28, 2014 3:31 pm
Location: Cambridgeshire

Re: No Power and limiting problem

Postby RS Tom-Hundred » Mon Jul 02, 2018 12:05 pm

I would try running the engine with a coil disconnected at a time to see if it drops that cylinder every time (if no change after removing a coil pack then that one is doing nothing and probably duff). This will put fault codes on though so make sure you clear them after.

Do the same with injectors to rule those out too maybe?

Other than that I'm not sure. Have you disconnected the battery overnight to clear ECU and reset. Might be worth a try but bare in mind that it may idle and/or run weird for the first 25-50miles after reconnecting ;)

Good luck and report back :)

Bref92-Tez
Noob!
Posts: 3
Joined: Thu May 31, 2018 11:42 am

Re: No Power and limiting problem

Postby Bref92-Tez » Mon Jul 02, 2018 12:32 pm

Thanks for the reply :D

So have been working on it over the weekend and have managed to fix the power problem (I hope :? ) but she is still limiting early. She is now limiting at 5000 rpm (this has been consistent so far).

Have tried coilpacks and injectors beforehand and all good. Have taken out the fuse to reset the ecu and also disconnected the battery on several occasions. Would it make a difference to leave it overnight? Normally just leave it for half and hour or an hour or so.

I have had different mechanics saying "it's only something small/simple" (bare in mind that they would be everyday mechanics that would only have limited experience with "performance car").

At this stage I feel like it's a process of elimination but it is becoming costly :shock:

So again, any ideas are welcomed :roll:

Tripp
Noob!
Posts: 6
Joined: Thu Apr 12, 2018 12:14 pm

Re: No Power and limiting problem

Postby Tripp » Thu Jul 05, 2018 8:53 am

Is it bouncing off the limiter at 5k rpm or does it just not go any higher?

Bref92-Tez
Noob!
Posts: 3
Joined: Thu May 31, 2018 11:42 am

Re: No Power and limiting problem

Postby Bref92-Tez » Thu Jul 05, 2018 2:58 pm

It bounces off the limiter at 5k rpm.


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron