Page 1 of 1

No Power and limiting problem

Posted: Fri Jun 29, 2018 11:56 pm
by Bref92-Tez
Hey, any help much appreciated.... :roll:

Long story so sorry in advance.

Started when I was testing my 99 tezz, I had to change my straight through to put a cat in for test. The car started limiting out around 6/6.5 rpm but just assumed it was as a result of the cat, she was still hitting vvti though. She passed test and changed back to the straight through exhaust but was still limiting out early and started to get worse. She started to limit at 5.5rpm then dropped to 4.5rpm. At this stage she was down on power, not hitting vvti and limiting at different stages. I changed the crank shaft sensor (advised to do this) no difference. I then changed bank 1 vvti soliniod and she was going up in the revs but still not hitting vvti. Changed bank 2, no difference and now is limiting at 3rpm and popping like mad when hitting near there.

To date I have:
Cleaned out the MAF sensor and throttle body (as she was ideling funny)
Changed the crank shaft sensor (no difference)
Changed bank 1 and 2 vvti sensor (slight improvement but still not right and has since started to deteriorate)
No engine management light up (light comes on so it's working)
Ran a diagnostic and no related faults reading

Any idea what it could be?

I may have forgotten things so will update if anything comes to mind.

Re: No Power and limiting problem

Posted: Mon Jul 02, 2018 12:05 pm
by RS Tom-Hundred
I would try running the engine with a coil disconnected at a time to see if it drops that cylinder every time (if no change after removing a coil pack then that one is doing nothing and probably duff). This will put fault codes on though so make sure you clear them after.

Do the same with injectors to rule those out too maybe?

Other than that I'm not sure. Have you disconnected the battery overnight to clear ECU and reset. Might be worth a try but bare in mind that it may idle and/or run weird for the first 25-50miles after reconnecting ;)

Good luck and report back :)

Re: No Power and limiting problem

Posted: Mon Jul 02, 2018 12:32 pm
by Bref92-Tez
Thanks for the reply :D

So have been working on it over the weekend and have managed to fix the power problem (I hope :? ) but she is still limiting early. She is now limiting at 5000 rpm (this has been consistent so far).

Have tried coilpacks and injectors beforehand and all good. Have taken out the fuse to reset the ecu and also disconnected the battery on several occasions. Would it make a difference to leave it overnight? Normally just leave it for half and hour or an hour or so.

I have had different mechanics saying "it's only something small/simple" (bare in mind that they would be everyday mechanics that would only have limited experience with "performance car").

At this stage I feel like it's a process of elimination but it is becoming costly :shock:

So again, any ideas are welcomed :roll:

Re: No Power and limiting problem

Posted: Thu Jul 05, 2018 8:53 am
by Tripp
Is it bouncing off the limiter at 5k rpm or does it just not go any higher?

Re: No Power and limiting problem

Posted: Thu Jul 05, 2018 2:58 pm
by Bref92-Tez
It bounces off the limiter at 5k rpm.