Page 1 of 1

Car backfiring when given full throttle and hesitates

Posted: Sun Mar 11, 2018 1:39 pm
by ZEditionAltezza
I bought my altezza around 3 months ago. it’s a 99 rs200 z edition sxe10.
been trying to solve this issue. it’s a M/T. whenever I give full throttle, it boggs out and backfires all the way till I let off the gas. this happens at 4.5-5krpms and will not go past that rpm. however if I go easy on throttle, it will reach redline. I have replaced the fuel pump, fuel injectors, iridium ik20 plugs, valve cover gasket, and put in a new battery. cleaned the thottle body and the MAF sensor. I also had the car scanned multiple times to check for any codes, but every time it passes and says no faults. the idle does fluctuate a bit I can feel it needs adjusting but am not sure if that has something to do with the backfiring issue. any suggestions ? hope I was clear on what I mentioned.

Re: Car backfiring when given full throttle and hesitates

Posted: Sun Mar 11, 2018 6:53 pm
by tommysheen
Check the plug gap. Something small but easy to check

Re: Car backfiring when given full throttle and hesitates

Posted: Mon Mar 12, 2018 12:26 pm
by ZEditionAltezza
I checked them today and regapped them. A bit of extra performance, however still does the same thing at full throttle 4.5-5krpm.

Re: Car backfiring when given full throttle and hesitates

Posted: Mon Mar 19, 2018 9:19 am
by RS Tom-Hundred
Try unplugging a coil in turn. (eg. Run engine, see how it sounds/backfires/misses cylinder then turn engine off unplug coil 1 retry to see if sounds same. Then plug that back in then remove coil 2 plug, start and see what it sounds like etc etc)

If you have got a coil breaking down, when you run it with that coil plug disconnected it wont run any different (compared to when you unplug a good coil the engine will miss that cylinder when running).

Worth a try to rule out but tbh that should throw an ignition codes so with no codes showing, that shouldn't be your issue.

Re: Car backfiring when given full throttle and hesitates

Posted: Thu Mar 29, 2018 2:11 pm
by Steve86
Did you manage to solve the problem. Please kindly give us any feedback for the benefit of others in the future. If not solved, I was thinking you check your catalytic convertors, they might be blocked.

Re: Car backfiring when given full throttle and hesitates

Posted: Sat Mar 31, 2018 5:44 pm
by tommysheen
It’s something to do with maf, plugs or coils or possibly fueling if it was blocked cat or anything like that it wouldn’t miss so much as just not have power like a blocked air filter type situation. If you know anyone with a Tezz that you could swap out the coils with I’d try that they are fairly common to go.
Do please keep us updated as it helps everyone else and the forum.

Re: Car backfiring when given full throttle and hesitates

Posted: Sun Apr 01, 2018 7:12 am
by ZEditionAltezza
I’ve cleaned up everything. the whole fuel system has been replaced. it still cuts me out. even when I first shift into a new gear and give it full throttle. mostly noticeable shifting first to second. it’s like a missfire where it keeps bogging for 2-3 seconds then gets performance (still backfires at4.5krpm). if I go half throttle, it goes very smooth and works it way to red line. I haven’t checked the cats, never thought they would have anything to do with it.

Re: Car backfiring when given full throttle and hesitates

Posted: Sun Apr 01, 2018 7:14 am
by ZEditionAltezza
tezza’s here are pretty rare. maybe 3-4 in town including mine? saw one up for sale once, but never seen one on the rode. never.

Re: Car backfiring when given full throttle and hesitates

Posted: Thu Apr 05, 2018 5:07 pm
by banan1984
What about VVTi solenoid? Could be blocked from oil sludge