ImageGreetings! Welcome to Tezzaworld website, unfortunately you are a few years late to the show as nearly everyone has been and gone, there is still lots of useful archived material to read through, not many active users unfortunately, but that’s the way it goes, hopefully you are not too disappointed...

Code P1354

Any problems with your Altezza, post questions here
Cathalsully-Tez
Noob!
Posts: 6
Joined: Fri Apr 06, 2018 7:15 am

Code P1354

Postby Cathalsully-Tez » Thu Apr 26, 2018 7:45 am

Hi my car seems to be running weird so looking for help yet again, got my obd port working so was able read codes and got p1354 vvt solenoid, had 2 spare out of my old engine and changed them out but problem is still there, if I delete codes the car will run perfect for a good 2 miles until the eml will come on again and goes off itself each time then the car is down on power and at 2000rpm there a little dead spot/shutter... anyone come across it been like this before have seen other posts with this code but changing the solenoid Normally fixes it for them...

User avatar
RS Tom-Hundred
Tezza Fanatic!
Posts: 471
Joined: Fri Nov 28, 2014 3:31 pm
Location: Cambridgeshire

Re: Code P1354

Postby RS Tom-Hundred » Fri Apr 27, 2018 1:25 pm

Presumably, once the EML comes back on and the rough running occurs, the original error code comes back?

Cathalsully-Tez
Noob!
Posts: 6
Joined: Fri Apr 06, 2018 7:15 am

Re: Code P1354

Postby Cathalsully-Tez » Fri Apr 27, 2018 11:02 pm

Yes once I clear codes and drive the car for a bit the eml will come on turn off after 30 seconds or so and when I read it again it’s the orginal p1354 code again each time, took it for a good drive today 200 miles or so, and drives great only for this it’s like as if the car is going into limp mode once the light comes on,


Return to “Problems with your Altezza”

Who is online

Users browsing this forum: No registered users and 0 guests

cron